Emerge config file needs updating

DO NOTE - I can not tell you what you can safely remove from your system as you need to know your hardware and what is safe to uninstall, remove from config files and remove from kernel.

I am going to try and stay very basic here so you can get the idea.

Multiple package instances within a single package slot have been pulled !!!

into the dependency graph, resulting in a slot conflict: dev-libs/openssl:0 (dev-libs/openssl-1.0.2k:0/0::gentoo, ebuild scheduled for merge) pulled in by =dev-libs/openssl-0.9.8f:0[bindist=] required by (net-misc/openssh-7.3_p1-r7:0/0::gentoo, installed) ^^^^^^^^ It may be possible to solve this problem by using to prevent one of those packages from being selected.

* See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order: Calculating dependencies... [ebuild N ] net-libs/http-parser-2.6.2 USE="-static-libs" ABI_X86="(64) -32 (-x32)" [ebuild R ] dev-libs/openssl-1.0.2k USE="-bindist*" [ebuild N ] dev-libs/libuv-1.10.2 USE="-static-libs" ABI_X86="(64) -32 (-x32)" [ebuild N ] net-libs/nodejs-6.9.4 USE="npm snapshot ssl -debug -doc -icu " CPU_FLAGS_X86="sse2" PYTHON_TARGETS="python2_7" [ebuild N ~] net-im/riot-web-0.11.4 USE="-websocket" ABI_X86="(64) -32" !!!

Web OS Goodies へようこそ! Web OS はインターネットの未来形。あらゆる Web サイトが繋がり、共有し、協力して創り上げる、ひとつの巨大な情報システムです。そこでは、あらゆる情報がネットワーク上に蓄積され、我々はいつでも、どこからでも、多彩なデバイスを使ってそれらにアクセスできます。 Web OS Goodies は、さまざまな情報提供やツール開発を通して、そんな世界の実現に少しでも貢献するべく活動していきます。 これは、設定ファイル(主に "/etc" 以下にあるもの)が更新されたため、手動でそれらを現在のファイルにマージする必要があることを示しています。Gentoo Linux では安全性を優先して、設定ファイルの更新はユーザーの判断で行うようになっているのです。手動といっても etc-update という専用のツールが用意されており、対話的に更新が行えるようになっているので、さほど大変ではありません。楽でもありませんが。(^^; それでは、さっそく設定ファイルの更新をやってみましょう。以下のようにして etc-update を起動します。コマンドラインオプションなどはとくにありません。 Scanning Configuration files...

The following is the list of files which need updating, each configuration file is followed by a list of possible replacement files.

What is your exact error with [email protected] ~ $ sudo emerge -a riot-web * IMPORTANT: 3 config files in '/etc/portage' need updating.

First let me say that there is a several ways to doing things on SL.

I am not saying that my way is the best way by any means.

First thing - I alway buy my hardware that I know is linux supported and has good drivers.

So get to know your hardware, I can't say that enough as it will save you a lot of headaches.

Leave a Reply